Please use the links below to download the correct GPS Log Book Sync Application installer for your operating system.

Be sure to check that you system meets the minimum requirements.

  • Microsoft Windows Operating System supporting .Net Framework 3.5 or above
  • Microsoft .Net Framework 3.5
  • Available USB Port

  • Mac OS X Leopard (10.5) or later
  • Available USB Port

This version of the Sync Application is specifically for customers from New Zealand.
Please follow these links for other countries:
South Africa
United Kingdom
United States

User Manuals